Website Outage
Incident Report for Packet
Resolved
Issues with our website have been resolved. Apologies for the interruption!
Posted 10 months ago. Feb 03, 2018 - 20:26 EST
Investigating
We are investigating an issue with our website. The portal is still available via https://app.packet.net/
Posted 10 months ago. Feb 03, 2018 - 19:55 EST